Project

General

Profile

Bug #3502

Refinement benchmarks: get an exception - Logic::getOriginalAssertion(PTRef): Assertion `flat2orig.find(flat) != flat2orig.end()' failed

Added by Karine Even Mendoza about 3 years ago. Updated about 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Start date:
09/09/2016
Due date:
% Done:

100%

Estimated time:

Description

Code: hi-bench/main-bench/funfrog_regression/09_refinement/t_diff_e.c --refine-mode 2 --init-mode 1 --no-summary-optimization

Error: evolcheck: ../../src/logics/Logic.h:262: PTRef Logic::getOriginalAssertion(PTRef): Assertion `flat2orig.find(flat) != flat2orig.end()' failed.
Aborted (core dumped)

SMTlib code: in the attachment.

t_diff_e_hifrog_lra.smt (68.4 KB) t_diff_e_hifrog_lra.smt Karine Even Mendoza, 09/09/2016 10:05

History

#1 Updated by Antti Hyvärinen about 3 years ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 100

Seems to be working now in hi frog / master and opensmt2 / master (I tested it both the c-file and the smt2 file you gave at the bug report).

Also available in: Atom PDF